Replicator window falls to bottom after Browse for Folder
Closed, ResolvedPublic

Description

JL wrote:

I believe there is a bug in Replicator 3.7.3: the program window minimizes and loses focus after selection of source and/or destination directories using the BROWSE button during job creation. This can lead to inadvertant clicks into any other open program window. AFAICT only the BROWSE buttons are affected. More info on request. Thanks!

The second topmost window pops to top after a folder browsing is completed to select a Source or Destination Folder.

This has been a problem since at least 3.7.0.

Joe created this task.Mon, Feb 11, 3:17 PM
Joe created this object in space S5 Public.
Joe triaged this task as Unbreak Now! priority.
Joe created this object with visibility "Public (No Login Required)".
Joe renamed this task from Replicator window falls to bottem after Browse for Folder to Replicator window falls to bottom after Browse for Folder.Fri, Feb 15, 6:30 AM
Joe closed this task as Resolved.Fri, Feb 15, 6:56 AM

Well, okay. I added the proper handle to the owner of the folder browser, and the problem went away. Then I reset it back to 0 like Karen had originally and still the problem had gone away. I'm not sure what I've missed, but going to mark this resolved.

Joe reopened this task as Open.Fri, Feb 15, 7:46 AM

Now the problem is back. Weirdness.

Joe added a comment.Fri, Feb 15, 7:51 AM

Added Me.SetFocus after selecting folder... which seems now to have made the problem go away. Removing the SetFocus causes the problem to return. SO, I'm calling it. RESOLVED. BEEN RESOLVED, baby.

And now, a kitten:

Joe closed this task as Resolved.Fri, Feb 15, 7:52 AM
Joe added a comment.Fri, Feb 15, 9:06 AM

The reason the fixes weren't working is because I'd caused VB6 IDE to crash before saving the source files to disk... So the debug version of the application had the fixes, but the next load of the project did not still have them.