Smart application termination with option to minimize on window close
Closed, ResolvedPublic

Description

Do:

  1. Prevent Replicator from interrupting a session shutdown, "The following application is preventing you from logging out" etc.
  2. Add option to minimize to the system tray instead of warning the user when they close the Replicator main foirm.

Will need to distinguish between form closure caused by Exit button and a system action, like the X close on the window.

Private Sub Form_QueryUnload(cancel As Integer, unloadmode As Integer)

vbFormControlMenu 0 ' The user chose the Close command from the Control menu on the form.
vbFormCode 1 ' The Unload statement is invoked from code.
vbAppWindows 2 'The current Microsoft Windows operating environment session is ending.
vbAppTaskManager 3 'The Microsoft Windows Task Manager is closing the application.
vbFormMDIForm 4 'An MDI child form is closing because the MDI form is closing.
vbFormOwner 5 'A form is closing because its owner is closing.
Joe created this task.Dec 6 2018, 10:48 AM
Joe created this object in space S5 Public.
Joe triaged this task as Normal priority.
Joe created this object with visibility "Public (No Login Required)".
Joe renamed this task from Option: Minimize to system tray instead of closing form to Smart application termination with option to minimize on window close.Dec 6 2018, 11:00 AM
Joe updated the task description. (Show Details)
Joe edited projects, added Replicator (v3.7.1 Released 2018-12-06); removed Replicator.
Joe closed this task as Resolved.
Joe claimed this task.

All fixed up.

Added "Minimize Window Instead of Closing" to Other Settings.

Tested that System Shutdown and Task Manager End Process will stop Replicator without putting up warning dialog.